IPV6 Configuration in Gns3:

IPV6 OSPF Configuration on Gns3:

This is the simple IPV6 tutorial for configuring IPV6 and OSPF for IPV6 on Gns3.  You must enable IPV6 routing on router by using command “ipv6 unicast-routing”, all other command are same like normal IP configuration but just replace IP with IPV6 in all commands. I use the c7200 IOS for this lab. Configure the topology as below:

R1 Configuration:
R1(config)#  ipv6 unicast-routing
R1(config)#  ipv6 router ospf 1
 R1(config-router)#  router-id 1.1.1.1
R1(config-router)# exit
R1(config-if)#  interface Loopback1
R1(config-if)#  ipv6 address 2001:211:10:1::1/64
 R1(config-if)#  ipv6 ospf 1 area 0
R1(config-if)#  interface Serial1/0
R1(config-if)#  ipv6 address 2001:210:10:1::2/64
R1(config-if)#  ipv6 ospf 1 area 0

R2 Configuration:

R2(config)#  ipv6 unicast-routing
R2(config)#  ipv6 router ospf 1
 R2(config-router)#  router-id 2.2.2.2
R2(config-router)# exit
R2(config-if)#  interface Loopback1
R2(config-if)#  ipv6 address 2001:211:10:1::2/64
 R2(config-if)#  ipv6 ospf 1 area 0
R2(config-if)#  interface Serial1/0
R2(config-if)#  ipv6 address 2001:210:10:1::1/64
R2(config-if)#  ipv6 ospf 1 area 0

IPV6 Verification Commands:
R# show ipv6 route
R# SHOW ipv6 interface brief
R# SHOW ipv6 ospf 1 neighbor

OSPF Non-Broadcast Configuration on gns3 (OSPF frame-Relay Configuration Lab):


Frame-Relay Hub and spoke Configuration:

In OSPF non-broadcast mode has following features:
·         All Router Must be on Same Subnet
·         Statically configure the Neighbors
·         Act Like a LAN Environment
·         DR/BDR are selected, since there is not broadcast therefore you select DR and DR-other by priority command.




GNS3 Frame-Relay switch Configuration:
Add the mapping as shown in figure for given topology.




R1 Configuration:

interface Serial1/0
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 255
 ip ospf 1 area 0
 serial restart-delay 0
 frame-relay map ip 10.1.1.2 200 broadcast
 frame-relay map ip 10.1.1.3 300 broadcast
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 neighbor 10.1.1.2 priority 0
 neighbor 10.1.1.3 priority 0
ip ospf priority 255

R2 Configuration:

interface Loopback1
 ip address 200.1.1.1 255.255.255.0
 ip ospf priority 0
 ip ospf 1 area 0
interface Serial1/0
 ip address 10.1.1.2 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 ip ospf 1 area 0
frame-relay map ip 10.1.1.1 100 broadcast
 frame-relay map ip 10.1.1.3 100 broadcast
router ospf 1
router-id 2.2.2.2

R3 Configuration:

interface Serial1/0
 ip address 10.1.1.3 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 ip ospf 1 area 0
 serial restart-delay 0
 frame-relay map ip 10.1.1.1 100 broadcast
 frame-relay map ip 10.1.1.2 100 broadcast
router ospf 1
 router-id 3.3.3.3



Verification commands:

Show frame-rel ay map
Show ip route
Show ip ospf 1 neighbour
Show ip ospf 1 process

  1. Ping all other router should be successful.
  2. Use the traceroute command to verify that R1 is hub and other are spoke.

R3#trac 10.1.1.2


UA-23728446-1